FlyVPN Linux 客户端

FlyVPN Linux download
操作系统 Kernel >= 2.6, Mainstream Distributions/OpenWRT/DD-WRT
软件版本 3.7.1.2
文件大小 1.1M - 1.6M
发布日期 2017-01-11
Intel/AMD: x86 (32-bit, 64-bit)
Embedded: armel mips mipsel
x86/armel/mips已经测试可用。mipsel未测试。如有问题请反馈给我们。

注意:OpenWRT/DD-WRT版仅供高端玩家研究,连接成功后通常还需要一些额外配置工作,我们暂时没办法提供所有场景下的支持,需要您自己发掘。

FlyVPN Linux Help

# wget THE-DOWNLOAD-URL

# tar -zxvf THE-DOWNLOADED-TAR-GZ

# vim /etc/flyvpn.conf
user YOUR-ACCOUNT-NAME
pass YOUR-PASSWORD

# ./flyvpn login
flyvpn 3.6.0.2 (core:160814-1519)
Load config file: /etc/flyvpn.conf
Command: login
Logging in ...
Login done.
=====================================================
Web Site: https://www.flyvpn.com/
Login Result: OK
Expiration: Sat Jul 22 23:53:39 2017
=====================================================

(View all usable VPN servers)
# ./flyvpn list

(View all usable VPN servers with tag "USA")
# ./flyvpn list "usa"

flyvpn 3.6.0.2 (core:160814-1519)
Load config file: /etc/flyvpn.conf
Command: list
      11	California 04 (Fremont,28IP)
      50	Oregon 02 (Portland,5IPs)
      57	Relay to USA 12 (Shanghai Telecom Relay To USA 12)
      77	Nevada 01 (Las Vegas,7IP)
      90	Relay to USA 13 (Shanghai Telecom Relay To USA 13)
      91	Georgia 01 (Atlanta)
      92	Relay to USA 14 (Shanghai Telecom Relay To USA 14)
      95	Relay to USA 15 (Shanghai Telecom Relay To USA 15)
     105	Relay to USA 16 (Shanghai Telecom Relay To USA 16)
     106	Relay to USA 11 (Shanghai Telecom Relay To USA 11)
     109	USA 13 (Los Angeles;5IP)
     123	Illinois 01 (Chicago,5IP)
     143	New York 01 (Long Island Via HK;3IP)
....


# ./flyvpn connect "California 04"
flyvpn 3.6.0.2 (core:160814-1519)
Load config file: /etc/flyvpn.conf
Command: connect
=====================================================
Web Site: https://www.flyvpn.com/
Login Result: OK
Expiration: Sat Jul 22 23:53:39 2017
=====================================================
Server: "California 04"
Please choose protocol [udp/tcp/lwip/socks5]: udp
2016-08-14 16:58:40 [I] flyvpn state = 102, rx = 608, tx = 1776
2016-08-14 16:58:40 [I] flyvpn state = 200, rx = 861, tx = 3132
2016-08-14 16:58:40 [I] flyvpn protocol: udp
2016-08-14 16:58:41 [I] flyvpn opened tun: tun0
2016-08-14 16:58:41 [I] flyvpn setting ip addresses and routes ...
2016-08-14 16:58:42 [I] flyvpn server: California 04, server virtual ip: 10.253.250.1
2016-08-14 16:58:42 [I] flyvpn tun: tun0
2016-08-14 16:58:42 [I] flyvpn dns: 8.8.8.8,8.8.4.4
2016-08-14 16:58:42 [I] flyvpn use vpn as default route gateway
2016-08-14 16:58:42 [I] flyvpn backup dns /etc/resolv.conf to /tmp/flyvpn-resolv.conf.backup
2016-08-14 16:58:42 [I] flyvpn update dns nameserver in /etc/resolv.conf
2016-08-14 16:58:42 [I] flyvpn done
^C
Signal: 2, stop & exit
2016-08-14 17:02:57 [I] flyvpn restore dns /etc/resolv.conf from /tmp/flyvpn-resolv.conf.backup
2016-08-14 17:02:58 [I] flyvpn state = 0, rx = 12170284, tx = 5971328
2016-08-14 17:02:58 [I] flyvpn stopped.

# ./flyvpn --help
show help for expert users: more options, up/down script, etc.

    

FlyVPN OpenWRT Tutorial

Permanent configurations (set up once and can be kept even if no VPN connection)
# opkg update; opkg install ip kmod-tun

# vim /etc/config/network
(Append these lines after config file)
config interface 'vpnnet'
        option ifname 'tun0'
        option defaultroute '0'
        option peerdns '0'
        option proto 'none'


# vim /etc/config/firewall
(Append these lines after config file)
config zone
        option name vpnzone
        option input ACCEPT
        option output ACCEPT
        option forward ACCEPT
        option masq 1
        option network vpnnet

config forwarding
        option src vpnzone
        option dest lan

config forwarding
        option src lan
        option dest vpnzone

# /etc/init.d/network reload
# /etc/init.d/firewall reload
Temporary configurations (set up before connection, restore after disconnection)
# vim /tmp/resolv.conf.vpn
nameserver 8.8.8.8
nameserver 8.8.4.4

# vim /etc/config/dhcp
(replace the default "option resolvfile" ...)
        option resolvfile '/tmp/resolv.conf.auto'
(to our DNS config file)
        option resolvfile '/tmp/resolv.conf.vpn'
(do remember to restore this option after disconnection and restart dnsmasq)

# /etc/init.d/dnsmasq restart
然后按照正常步骤,使用客户端程序登录并连接。现在所有用这个路由器的计算机都可以通过vpn访问网络了!
Open source licenses: lwIP libevent zlib curl mbedtls

发布历史